Saturday, October 5, 2019
English Essay Confessions of an Economic Hit Man
English Confessions of an Economic Hit Man - Essay Example After having left his job he wrote this book and is nowadays ahead of the movement that proclaims the increase of social, economic and ecological responsibility of businesses. After leaving his job as an economic hit man, Perkins founded the Independent Powers System, Inc. in1980 ââ¬â a company in a very risky sphere ââ¬â and later became the defender of the aboriginal rights in Amazonia, published several books on social responsibility, founded several non-profit organisations, among which is a famous Dream Change Coalition that, on the one hand, inspires people to achieve their goals, and on the other ââ¬â invites them to be extremely careful about how their lives influence the rest of the society and our planet in the whole. All these facts make it obvious that Perkins is sincere in his book, and that it is not a purely PR campaign designed to turn attention to himself but truly precious confessions that make people aware of the crimes performed against the global community by certain structures and separate people. After all, it was not before the September 11, 2001 attacks that John Perkins decided to write about his activity as an econom ic hit man, disregarding all the threats that he had to face. Perkins was firm in his decision to share his knowledge about the contribution of the USA government and multiple global corporations into making these tragic events possible. According to John Perkins, the ââ¬Å"helpâ⬠that the corporations and other organisations promised to the third-world countries, eventually turned out to be a disaster for people in these countries. Being an economic hit man, John Perkins travelled all over the world and took part in dramatic events of the modern history, including the money washing in Saudi Arabia, the defeat of the Iran Sheikh, the death of Panama President Omar Torrijos, and many others. In his
Friday, October 4, 2019
Theoires Of International Political Economy Essay
Theoires Of International Political Economy - Essay Example This essay discusses that Karl Marx, who was a staunch communist and opponent of capitalism, developed the Marxism theory. He highlighted that capitalism introduced a system governed by money. This aspect divided the society into two classes. Those who had money as well as a means of production qualified as the capitalists, which he referred to as the bourgeoisie and the laborers whom he called the proletariat. The laborers did not have the capital and were hence unable to access a means of production. The purpose of the capitalists was to ensure that their systems registered the highest profits but minimal costs. This means that they were only willing to pay little wages to the laborers. On the other hand, the laborers purposed to get the highest possible wage while doing the least work possible. Evidently, the needs for both classes were contrary to each other a factor that introduced class conflicts as Marx highlighted. As described above, different historians and economists descr ibed the three economic theories. Their relevance in the modern day cannot receive any form of underestimation. Different historians have highlighted that Mercantilism is of significance because it highlights the specific roles that a strong state should play if it is to promote the economic stability and the reinforcement of liberal rules across the globe. On the other hand, there is evidence that Marxism answers the increasing questions on why there is under development in third world countries.
Thursday, October 3, 2019
Fiction-writing mode Essay Example for Free
Fiction-writing mode Essay Rhetorical modes are methods for effectively communicating through language and writing. Complete the following chart to identify the purpose and structure of the various rhetorical modes used in academic writing. Provide at least 2 tips for writing each type of rhetorical device. |Rhetorical Mode |Purpose ââ¬â Explain when or why |Structure ââ¬â Explain what organizational |Provide 2 tips for writing in | | |each rhetorical mode is used. |method works best with each rhetorical mode. |each rhetorical mode. | |Narration |The purpose of a narration is to| | Start with asking yourself if | | |tell stories. Narrations can be |Chronological order, which is a method of |you want to write a factual or | | |factual; story based on events |organization that arranges ideas according to|fictional story. Next, make a | | |as they happened in real life, |time, is the best organizational method for |plot summary, which is a | | |or fictional; made up or |narration. |paragraph or outline that | | |imagined | |describes only the main events | | | | |that drive the story forward. | | |The purpose of an illustration |Order of importance, which is a method of |First, decide on a topic that | |Illustration |is to clearly demonstrate and |organization that arranges ideas according to|you are interested in writing | | |support a point through the use |their significance, is the best |about. Secondly, vary the phases| | |of evidence. |organizational method for illustration. |of illustration you use. This | | | | |way, readers will stay engaged | | | | |in your writing and ideas. | |Description |The purpose of a description is |Spatial order, which is a method of |Does your writing follow a flow?| | |to make sure the audience is |organization that arranges ideas according to|Good writing is focused. Is | | |fully immersed in the words on |physical characteristics or appearance, is |writing written for a purpose? | | |the page. The writer describes |the best organizational them. |Good writing is grammatically | | |his or her world through sensory| |correct a
Internet Protocol Version 6 (IPv6) Analysis
Internet Protocol Version 6 (IPv6) Analysis Overview Internet Protocol version 6 (IPv6) is the next generation of protocol defined by InternetEngineering Task force (IETF) to replace the exiting IPv4 protocol. At present, the majority of Internet users are still using IPv4 protocol, and given that most of current networking applications and network equipment run in IPv4 environments, the migration from IPv4 to IPv6 cant be accomplished overnight. It is predictable that the migration will be a long-term process (it is forecasted that the process will take 10 20 years). During the migration, IPv4 and IPv6 will coexist in a same network. This migration process poses new challenges on the routers that are the core equipment in IP network. Traditional routers cant accommodate new future network with IPv4/v6 coexistence. The routers must be improved and upgraded so that they can support both IPv4 and IPv6.Given that the core router is very important and carries huge Internet traffics, it must be able to support IPv6 forwarding at wire rate. It means ASIC chip, but not software is used to support IPv6 packet processing. At the same time, it is very important that this support cant sacrifice any IPv4 performance. After all, most of current traffics is IPv4. The core router must expand to support IPv6 routing tables and needs to support IPv6 routing protocols, such as BGP4+, OSPFv3, ISISv6, RIPng and etc. It needs to support some migration strategy from IPv4 to IPv6, such as Tunnel, Dual Stack, Translation and etc. Same as many network technologies, successful deployment of IPv6 relies on the deployment of the operators IPv6 network. As one core component in IPv6 network, IPv6 core router is key to network building, applications, performance and stability. At present, mainstream router vendors like Cisco and Juniper announce that their routers can support IPv6 while some traditional IT equipment manufactures, especially those in Japan, think Internet upgrade caused by IPv6 will change the whole landscape of router market, which brings significant opportunities for them to enter router market. From 2000 to 2002, Hitachi, NEC and Fujitsu announced IPv6-capable core router to gain some market share in new Internet network. It must be admitted that IPv6 is still in the initial phase at present, which is reflected in the following aspects: most IPv6 network is in trial phase, the number of access users is low, carried IPv6 traffics cant be comparable to IPv4, the interoperability between IPv6 equipment still needs to be proved, and network engineers lack in experience in large-scale deployment and operation of IPv6 network. The lack of data and experience is one of important causes that make some operators lack in confidence in IPv6 network deployment. Many operators take wait-and-see attitudes. In order to prove IPv6 router (especially IPv6 core router), the support to IPv6, how are they performed and interoperated, provide a practical data basis for the operators to deploy IPv6 network and provide a reference for equipment manufactures to evaluate and improve their equipment, BII(Beijing Internet Institute) collaborate with 6TNet (IPv6 Telecom Trial Network) in China tested IPv6 core routers from 4 ven dors (Fujitsu, Hitachi, Juniper and NEC) in Beijing from October to December 2002. BII performed protocol conformance, performance andà interoperability tests. In these tests, we used the test instruments provided by Agilent and received strong technical support from Agilent. The test is not a comparative performance test in different router vendors. The purpose is to verify the feasibility of IPv6 deployment. With this test, the test team thinks that all SUT (system under test) has the ability to support commercial IPv6 network and provide basic IPv6 capabilities. They can support IPv6 routing protocols, support the forwarding of IPv6 datagram at wire rate and provide interoperability between them. From perspectives of pure technology, the test team thinks the products have been ready to deploy basic IPv6 core network.. Brief Descriptions of Test The requirements for hardware provided by the SUT (system under test) are as follows: IPv6-capable core router OC48 SM ports (both ports must be in different boards) Supports both FE ports and GE ports. The number of FE ports and GE ports is no less than 3 Finally, all vendors basically meet those requirements, although CX5210 provided by NEC doesnt support FE during the time of testing. The requirement for IPv6 capabilities provided by the SUT (system under test) include: support of IPv6 forwarding in hardware and support of related IPv6 routing protocols and migration strategy. Finally, all vendors meet our requirements as shown in the following table. Company IPv6 hardwareDual Stack RIPng OSPFv3 BGP4+ IPv6 over IPv4 forwarding Tunnel Fujitsu 9 9 9 9 9 9 Hitachi 9 9 9 9 9 9 Juniper 9 9 9 9 9 9 NEC 9 9 9 9 9 9 The SUT (system under test) models and OS versions are shown in the following table. Company Model Version Fujitsu Geostream R920 E10V02L03C44 Hitachi GR2000-20H S-9181-61 07-01 [ROUTE-OS6] Juniper M20 5.5R1.2 NEC CX5210 02.0(2e) 45.08.00 The test instruments we used in the test are as follows: Agilent Router Tester 900 Version: Router Tester 5.1,Build 11.15. Agilent QA Robot Version: Router Tester 5.3,Build 5.2 The IPv6 core router test is composed of three parts: Protocol conformance test, interoperability test and IPv6 performance test. Basic IPv6 Protocols and RIPng Basic IPv6 protocols include IPv6 Specification (RFC2460), ICMPv6 (RFC2463), Neighbor Discovery (RFC2461), Stateless Autoconfiguration (RFC2462), Path MTU Discovery (RFC1981), IPv6 address Architecture (RFC1884) and etc., which are basic capabilities provided by an IPv6 implementation. RIPng is defined by RFC2080 and is the extension and expansion of RIPv2. Its basic capabilities are same as RIPv2. The routing information exchanged by RIPng can carry IPv6 addresses and prefixes. RIPng runs on IPv6 network, uses multicasting address ff02::9 as destination to transfer routing information. RIPng is not compatible with RIPv2. RIP protocol is typically used in small networks and is not deployed in large networks because of its scalability and performance, which is same in IPv6 networks. The test does not include basic IPv6 protocols and RIPng because we think both capabilities are most basic and most preliminary capabilities that should be provided in an IPv6 router, these capabilities are implemented and interoperated very well in the routers from 4 vendors, and the 4 tested routers have been tested publicly or non-publicly several times in different occasions and provided good data. Therefore, we think it is unnecessary to make efforts to repeat these work and we skipped this test and focused on more challenged test items. BGP4+ Protocol Conformance Test At present, the external gateway protocol used in the IPv4 network is BGP4. Its basic protocols are defined in RFC1771. In order to carry IPv6 network information in BGP4 updates, IETF has defined a special property multi-protocol BGP (MP-BGP), also called IPv6 NLRI (Network Layer Reachability Information) to exchange IPv6 routing information, which is not a new version of BGP protocol, but an extension to BGP4. The extension is generally called BGP4+, which is compatible with BGP4. Refer to RFC2545 for its definition. Test Purpose and Used Standards: Purpose: To test the implementation of BGP4+ and conform with related standards for SUT (System Under Test). The following standards are referred in the test: Bates, T., Chandra, R., Katz, D. and Y. Rekhter, ââ¬Å"Multiprotocol Extension for BGP-4â⬠, RFC 2858, Jne 2000. Bates, T., Chandra, R., Chen, E., ââ¬Å"BGP Route Reflection An Alternative to Full Mesh IBGPâ⬠, RFC2796, April 2000. Chandra, R. and J.Scudder, ââ¬Å"Capabilities Advertisement with BGP-4â⬠, RFC 2842, May 2000. Dupont, F. and P. Marques, ââ¬Å"Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routingâ⬠, RFC 2545, March 1999. Rekhter, Y. and T. Li, ââ¬Å"A Border Gateway Protocol 4 (BGP-4) â⬠. Traina, P., McPherson, D., Scudder, J., ââ¬Å"Autonomous System Confederations for BGPâ⬠, RFC3065, February 2001. Test Methods: All the tests are based on topology emulation. One test port of instrument firstly establishes network topology emulation, then executes pre-written scripts, interacts with the port of SUT, performs related BGP4+ protocol tests individually and each test generates Passed/Failed record. The tests can be divided into active tests and passive tests. Active test means the tester is used to verify the state machine of SUT and the correctness of message format while passive test means the tester is used to interfere with SUT using messages with errors. Test Topology Test instrument and SUT use two independent Fast Ethernet or Gigabit Ethernet connections. All BGP4+ runs on the Fast Ethernet or Gigabit Ethernet connections. The physical topology is as follows: The logical topology is as follows: Test Items and Descriptions of Test Results: The BGP4+ protocol conformance test involves in the BGP multi-protocol extension, setup and transfer of BGP4+ IBGP and EBGP sessions, ability to receive IPv6 route updates, BGP4+ next hop, starting point, MED, local preference, AS_PATH, atom aggregation, community name and various properties, the ability of SUT to correctly process these properties, BGP4+ route reflector capability, BGP4+ federation capability. These tests can only ensure implementation of BGP4+protocol in SUT comply with the standard defined by RFC, and cant ensure SUT fully and successfully deploy BGP4+ routes in commercial IPv6 network. The following diagram briefly describes the test results. Attached table 1 includes all test items, description and detailed results of BGP4+ conformance tests for 4 routers. The test items and descriptions are extracted from RFC2858, RFC2545, RFC2842, RFC2796, RFC3065 and draft-ietf-idr-bgp4-14.txt part. Model Failed test items Fujitsu GeoStream R920 2 Hitachi GR2000-20H 5 Juniper M20 1 NEC CX5210 3 Analysis of Test Results: Capabilities not supported Confederation Route reflector, Community Fujitsus GeoStreamR920 of current version does not support BGP4+ federation capability. In all BGP4+ test items it supported, the general performance is fairly good. What needs to be improved is only one item that is to support the migration of undefined property and handle interim duration. It is hoped to improve null interface which cant support next hop at present. Hitachis GR2000-20H of current version supports all test items, and is only product fully supporting BGP4+ protocols in the core routers from 3 Japanese companies. However, it needs to be improved in the following areas: handling next-hop property of IBGP in BGP4+ protocol, using AS_PATH properties to prevent from route loop, the ability of route reflector to detect ORIGINATOR_ID. At the same time, we found in the interoperability test that GR2000-20H cant establish non-physical direct-connection sessions with IBGP peering entities, which Hitachi needs to improve. It is hoped to add loopback address capability. Junipers M20 passes all tests except one item excellently. NECs CX5210 of current version doesnt support BGP4+ route reflector and community properties. In all BGP4+ test items it supported, the general performance is fairly good. However, it needs to be improved in handling BGP4+ federation AS_CONFED_SEQUENCE property. It is hoped to add null interface configuration. Interoperability Test As above mentioned, IPv6 is in initial phase of commercial deployment at present. A large amount of IPv6-capable network equipments and terminals are available. IPv6 network built by the operators doesnt only use the equipment provided by a vendor. In multi-vendor network environment, the interoperability between equipment is vital. The interoperability test is composed of BGP4+ interoperability test and OSPFv3 interoperability test. It should be noted that specific items in the interoperability test only cover some most common properties of BGP4+ and OSPFv3, and are not the interoperability tests of all properties of BGP4+ and OSPFv3. BGP4+ Interoperability Establish IBGP Sessions Test Descriptions: The test is to verify GR2000-20H, CX5210, R920,M20 and fully meshed iBGP connections that can be established. Reference: RFC1771, RFC2545 and RFC2858. Test steps: GR2000-20H, CX5210, R920, M20 and SUT are connected as shown in the following diagram. 4 routers are in a same autonomous domain and are interconnected using IBGP protocol to form a full-meshed IBGP connection. Test instrument and SUT are interconnected using EBGP connection. Because GR2000-20H doesnt support IBGP across-router Session connection, we use a FE link to connect GR2000-20H to M20 to form a fully-meshed connection. Test Results: We verified whether iBGP sessions were established between GR2000-20H, CX5210, R920 and M20, and it was found all connections were set up successfully. GR2000-20H CX5210 R920 M20 GR2000-20H N/A OK OK OK CX5210 OK N/A OK OK R920 OK OK N/A OK M20 OK OK OK N/A EBGP- Route Advertisement Test Descriptions: To verify GR2000-20H, CX5210, R920 and M20 can advertise routes properly in a fully meshed networks. References: RFC1771, RFC2545 and RFC2858. Test steps: Establish network topology according to previous test, establish eBGP connection between tester and SUT, send 100 EBGP routes from tester to SUT. Results: We verified whether GR2000-20H, CX5210 and R920 and M20 routing tables were correct, and it was found all routing tables were correct. GR2000-20H CX5210 R920 M20 GR2000-20H N/A OK OK OK CX5210 OK N/A OK OK R920 OK OK N/A OK M20 OK OK OK N/A Establish EBGP Sessions Test Descriptions: The test is to verify GR2000-20H, CX5210, R920 and M20 can establish a fully meshed eBGP connections. Reference: RFC1771, RFC2545 and RFC2858. Test steps: GR2000-20H, CX5210, R920 and M20 are connected as shown in the following diagram. Test Descriptions: We verified whether EBGP sessions were established between GR2000-20H, CX5210, R920 and M20, and it was found all connections were established successfully. GR2000-20H CX5210 R920 M20 GR2000-20H N/A OK OK OK CX5210 OK N/A OK OK R920 OK OK N/A OK M20 OK OK OK N/A EBGP Route Advertisement Test Descriptions: To verify GR2000-20H, CX5210, R920 and M20 can advertise EBGP routes properly. References: RFC1771, RFC2545 and RFC2858. Test steps: Establish network topology according to previous tests, send routes from each router to all other routers. Test Results: We verified whether GR2000-20H, CX5210 and R920 and M20 routing tables were correct, and it was found all routing tables were correct. GR2000-20H CX5210 R920, M20r GR2000-20H N/A OK OK OK CX5210 OK N/A OK OK R920 OK OK N/A OK M20 OK OK OK N/A OSPFv3 Interoperability OSPF protocols supporting IPv6 is OSPFv3. OSPFv3 routing mechanism is basically same as OSPFv2. However, OSPFv2 relies primarily on IPv4, while OSPFv3 makes many improvements in OSPFv2 and is not a simple extension, thus OSPFv3, whose corresponding protocol is RFC2740, runs on IPv6. For real world applications, many operators regard OSPFv3 as a brand new protocol, also its stability and maturity need to be further verified, so when IPv6 routing protocols are selected, it tends to use IS-ISv6 (draft-ietf-isis-ipv6-02.txt), which is only a simple extension to IS-ISv4 (RFC1195) (2 TLVs re-defined) and does not make changes fully. However, it is sure the opinion is not authoritative and need to be proved. Because of the limitations of test instrument, It is required for SUT to provide 100M Ethernet interface. As CX5210 does not support Ethernet interface at present, just M20, R920 and GR2000-20H were involved in the testing. However, it does not imply that CX5210 cant interoperate with other 3 routers and has any problems with functions implementation. In the test, GR2000-20H is called SUT1 in short, M20 is called SUT2, and R920 is called SUT3. Establish OSPF Connections DR Election Test Descriptions: In the initial status, set different OSPF priority levels for SUT1, SUT2, SUT3 and the test instrument (10, 8, 5, 0). Connect these equipments based on the network topology below. Verify SUT1, SUT2, SUT3 and test instrument to establish OSPFv3 adjacency and vote DR/BDR. After DR/BDR is established properly, put DR off the network, and check whether DR/BDR is established properly. Put off-net equipment on the network, and check whether DR/BDR is established properly. Change OSPF initialization priorities of SUT1, SUT2, SUT3 and test instrument, and implement new test from step 2. Repeat the tests for 4 times, and ensure each SUT and test instrument have one opportunity to be selected as DR and BDR under the intial status. During the test, all SUTs are in the same OSPF Area 0. Reference: RFC2740 Test Results: During the testing, all the OSPF adjacencys can be established between SUTs and DR, also BDR can be elected properly. After DR is off-line, BDR can be re-elected as DR and the one with sub-top priority will be BDR. When off-line equipment is on-line again, no re-electing process occurs. All test results comply with the requirements in related standards. Exchange LSA Database Test Descriptions: Test instrument simulates an internal network with 4 routers connected, and sends the routing information to SUT. Then verify the routing information received by SUT DR from test instruments will be sent to DR Other correctly. Same as the previous test item, firstly SUT1 is used as DR, then SUT2, and finally SUT3. Reference: RFC2740 Test Results: During the testing, OSPF adjacency can be established properly between all SUTs. DR receive LSA information from test instrument and properly send the information to DR Other, which can also receive and process LSA information properly. IPv6 Performance Test The major approach used for the performance testing was to send the IPv6 traffic with different packet sizes and specific QoS information, via SUT to the destination, and then by the tester measure the throughput, latency and packet loss of SUT in various topologies. For the IPv6 performance test, there are four vendors high-end IPv6 routers, with OC-48 POS ports on which throughput and latency will be measured, with IPv6 packet sizes of 64 bytes, 128bytes, 256 bytes, 512 bytes, 1024 bytes, 1480 bytes and 1500 bytes. The performance in various of circumstances were measured, including IPv4/IPv6 mixed traffics (IPv4 and IPv6 traffics with different ratio), IPv6 traffic with packet sizes mixtures, Sweep Packet Sizes. Also the maximum routing table entry supported and the performance on manually configured tunnels were verified. Most of the referred standards is extracted from RFC2544. At present, there are deficient applications for IPv6, and the number of users in the IPv6 network can not be compared to IPv4. The sum of maximum IPv6 of IX(Internet eXchage) traffics is less than dozens of Mbits/s. These traffics can be handled using a router refitted from a PC. Based on the circumstance, is it necessary to test the performance of OC48 ports ? Actually when the operators build IPv6 network and purchase IPv6 routers, todays IPv6 network is not under their consideration. Their networks should be able to deal with the changes and growth of IPv6 network next 5 7 years. In this sense, it is necessary for IPv6 core router to support the IPv6 traffic forwarding capacities at wire rate. Otherwise, what differences can be made between a real IPv6 router and a router refitted from a PC with installed BSD and Zebra ? The measurement of the number of routing table entry also meets the same situations. At present, therere around 300-400 entries in the IPv6 backbone router routing table, which cant compared to the huge number of IPv4 (110,000à ¼Ã 130,000 routes). Secondly, IPv6 has drawn experience and lessons from IPv4 in design and address assignment. RIR only assigns the large block and fixed length IPv6 addresses to IPv6 operators, instead of the end users. To some extent, this can protect IPv6 routing tables from the explosive growth. The strict prefix filtering mechanism was set on BGP4+ routers by most of IPv6 network administrators and the router only allows minor prefixes, such as /16, /24, /28, /32, /35 and etc. However, the experience of IPv4 teach us a lesson- ââ¬Å"Money Talks!â⬠. In the fiercely competitive ages, it is very difficult for operators to reject users requirements. Under the conditions that IPv6 doesnt solve the problems of Multi-homing completely, it is possible that the network operators are required to broadcast users network prefixes into global IPv6 routing tables in order to achieve Multi-homing applications. So far RIR has begun to assign /48 ad dress segment to IPv6 of IX independently, while it is suggested IX doesnt broadcast the addresses. Thirdly, in many IPv6 networks, there are at least two IPv6 addresses segments, from 6BONE(3ffe::/16) and RIR(2001::/16) respectively, and maybe more prefixes will appear in the future. Fourthly, RIR cant ensure IPV6 addresses assigned to IPv6 operators are from a continuous address block. Current assignment policy indicates that /32 addresses of IPv6 assigned to operators can be continuously extended to /29. If new addresses are further required, they must be assigned to discontinuous address blocks and result in the growth of the number of routing tables. To sum up, the test team suggests that the number of IPv6 routing tables supported by the router should be no less than that of IPv4 routing tables, since it is very difficult to estimate the increasing number of routing tables of IPv6 core network right now. In current IPv6 networks, commercial IPv6 network and IPv6 trial network (6BONE) are interlaced without a explicit boundary between them. A packet from commercial IPv6 network may go through many IPv6 trial network before arriving at another IPv6 network. The network administrators of many trial networks are not regarded as a ââ¬Å"operatorsâ⬠, but a ââ¬Å"playersâ⬠It is pretty unstable of their networks, with routers reset very frequently. In the meantime, the networks advertise global IPv6 routes to all peers, making their own IPv6 network to implement transit. It causes the instability of current IPv6 of BGP routes, and thus it is required the capabilities of IPv6 routers cover the flapping and convergence properly, which should be included in this test, however due to limited test time frame, it is a pity the test team has to give up these tests. The network topology used for the performance test is shown as following: Ideally, the test topology should be as following, so that the packet forwarding capability of the routers in real-world network environment is shown completely. Send one traffic from a source port of the tester, via multiple ports of the router to the destination ports of tester, measure the performance of the router. However as the vendors cant provide enough OC48 ports, the test team can only perform the test by simply sending packets from one port and receiving packets form another port. In this sense, this test environment cant simulate completely the performance of the router in the real-world network environment. The Measurement of Throughput and Latency with Different IPv6 Packets Sizes at OC-48 POS port Test Descriptions: To test the maximum IPv6 packet forwarding rate of SUT with zero packet loss with different IPv6 packet sizes. Test Methods: Send IPv6 packets, via SUT to the destination ports of the tester, which measures the packet rate of SUT according to the received IPv6 packets. Set the initial offered load to 2%, and If no packet loss occurs, increase the offered load to 100% and repeat the test. If packet loss occurs, decrease the offered load to (100%+2%)/2=51%, repeat the test againâ⬠¦Ã¢â¬ ¦In a binary search manner, continue to increase or decrease the offered load in subsequent iterations until the difference in offered load between successful and failed tests is less than the resolution for the test. This is the zero-loss throughput rate. Traffic forwarding mode: full duplex. Offered Packet type: IPv6; Offered Packet size (bytes): 64 128 256 512 1024 1480 1500 Test duration of each packet type(s): 5 Bandwidth resolution (%): 0.1 Line BER tolerance (10^_): -10 The results are as follows: Sustainable Throughput of OC-48 POS Port 105.00% 100.00% 95.00% 90.00% 85.00% 80.00% 75.00% 70.00% 65.00% 60.00% 55.00% 50.00% 64 128 256 512 1024 1480 1500 bytes bytes bytes bytes bytes bytes bytes Test Packets Size Average Latency (us) at Variable Test Packets Size 100 90 80 70 60 50 40 30 20 10 0 Test Packets Size Hitachi NEC Fujistu Juniper Hitachi NEC Fujistu Juniper Note: About inherent latency of tester Before we perform tests, we must consider intrinsic latency of tester. The following table indicates inherent latency of tester for different test packet sizes when sending 100% offered load. Inherent latency of tester (100% offered load) Packet Size (bytes) 64 128 256 512 1024 1480 1500 Average Inherent 2.74 2.69 2.69 2.65 2.65 2.60 2.60 Latency (us) From the above, the inherent latency of tester under different packet sizes is about 2.7us. Compared to the tens of us of SUTs latency, there are not significant impacts on the test results. In addition, the impact of inherent latency is fair to these 4 SUTs. Forwarding Performance of IPv4/IPv6 Packets on OC48 Ports Test Descriptions: To verify the performance of SUT to forward IPv4/IPv6 packets in offered packets sizes. The test requires SUT to support IPv4/IPv6 dual protocol stacks. Test Methods: The tester sends IPv4 and IPv6 traffic simultaneously in full duplex configuration, via SUT to the destination port, measure the throughput and latency with various ratio of IPv4 and IPv6 traffic. Send traffic with 50% of IPv4 and 50% of IPv6 and 100% offered load first time. If packet loss occurs, decrease the offered load in 5% resolution until the difference in offered load between successful and failed tests is less than the resolution for the test. This is the zero-loss throughput rate. At the same time, measure the latency at maximum forwarding rate. Then change the ratio of IPv4 and IPv6 traffic to test again. Increase continuously the proportion of IPv6 traffic to simulate the change of traffic characteristics in the real-world network transition. Test Descriptions: Offered load (%): initial100% with 5% increment and final 0 Offered packet types: IPv6 Percentage of IPv4 and IPv6 traffic: 50:50ââ¬â10:90 (IPv4:IPv6) Offered packet size (bytes): 62 512 1518 Test duration of each packet size(s): 5 The test results are as follows: Sustainable throughput of OC-48 POS port at packet size 64 bytes with different percentage of IPv4 and IPv6 traffic Sustainable Throughput of OC-48 POS Port at Packet Size 64 bytes with different Percentage of IPv4 and IPv6 Traffic 105% 100% 95% 90% 85% Hitachi 80% NEC 75% Fujistu 70% Juniper 65% 60% 55% 50% 50/50 40/60 30/70 20/80 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Sustainable throughput of OC-48 POS port at packet size 512 bytes with different percentage of IPv4 and IPv6 traffic Sustainable Throughput of OC-48 POS Port at Packet Size 512 bytes with different Percentage of IPv4 and IPv6 Traffic 105% 100% 95% 90% 85% Hitachi 80% NEC 75% Fujistu 70% Juniper 65% 60% 55% 50% 50/50 40/60 30/70 20/80 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Sustainable throughput of OC-48 POS port at packet size 1518 bytes with different percentage of IPv4 and IPv6 traffic Sustainable Throughput of OC-48 POS Port at Packet Size 1518 bytes with different Percentage of IPv4 and IPv6 Traffic 105% 100% 95% 90% 85% Hitachi 80% NEC 75% Fujistu 70% Juniper 65% 60% 55% 50% 50/50 40/60 30/70 20/80 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Average latency (us) at test packets size 64 bytes with different percentage of IPv4 and IPv6 traffic Average Latency (us) at Test Packets Size 64 bytes with Different Percentage of IPv4 and IPv6 Traffic 100 90 80 70 60 50 40 30 20 10 0 50/50 40/6 30/70 20/80 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Hitachi NEC Fujistu Juniper Average latency (us) at test packets size 512 bytes with different percentage of IPv4 and IPv6 traffic Average Latency (us) at Test Packets Size 512 bytes with Different Percentage of IPv4 and IPv6 Traffic 100 90 80 70 60 50 40 30 20 10 0 50/50 40/60 30/70 20/80 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Hitachi NEC Fujistu Juniper Average latency (us) at test packets size 1518 bytes with different percentage of IPv4 and IPv6 traffic Average Latency (us) at Test Packets Size 1518 bytes with Different Percentage of IPv4 and IPv6 Traffic 100 90 80 70 60 50 40 30 20 10 0 50/50 40/60 30/70 20/80à à à à 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Hitachi NEC Fujistu Juniper IPv6 over IPv4 Configured Tunneling Performance of OC-48 POS Port Test Description: Tunneling technology is an effective means to connect separate IPv6 networks via IPv4 backbone. This item is to verify the performance of SUT when SUT encapsulates IPv6 data packets into IPv4 payload and forwards the packets. Test Method: The tester sends IPv6 data packets to SUT, and configures an IPv6 over IPv4 tunnel between SUT and the tester. Thus after SUT receives pure IPv6 packets from the tester, it will encapsulate it into IPv4 packet payload, and send IPv6 packets to destination over IPv4 network. The tester analyzes the packets forwared by the SUT at receiving end, calculates the throughput of SUT for different sizes of packets under the IPv6 over IPv4 configured tunnel. Test Results: IPv6 packet size: 512 Destination address of sending IPv6 data packets: 3FFE:0:0:4::2/64 Bandwidth range of sending IPv6 tra Internet Protocol Version 6 (IPv6) Analysis Internet Protocol Version 6 (IPv6) Analysis Overview Internet Protocol version 6 (IPv6) is the next generation of protocol defined by InternetEngineering Task force (IETF) to replace the exiting IPv4 protocol. At present, the majority of Internet users are still using IPv4 protocol, and given that most of current networking applications and network equipment run in IPv4 environments, the migration from IPv4 to IPv6 cant be accomplished overnight. It is predictable that the migration will be a long-term process (it is forecasted that the process will take 10 20 years). During the migration, IPv4 and IPv6 will coexist in a same network. This migration process poses new challenges on the routers that are the core equipment in IP network. Traditional routers cant accommodate new future network with IPv4/v6 coexistence. The routers must be improved and upgraded so that they can support both IPv4 and IPv6.Given that the core router is very important and carries huge Internet traffics, it must be able to support IPv6 forwarding at wire rate. It means ASIC chip, but not software is used to support IPv6 packet processing. At the same time, it is very important that this support cant sacrifice any IPv4 performance. After all, most of current traffics is IPv4. The core router must expand to support IPv6 routing tables and needs to support IPv6 routing protocols, such as BGP4+, OSPFv3, ISISv6, RIPng and etc. It needs to support some migration strategy from IPv4 to IPv6, such as Tunnel, Dual Stack, Translation and etc. Same as many network technologies, successful deployment of IPv6 relies on the deployment of the operators IPv6 network. As one core component in IPv6 network, IPv6 core router is key to network building, applications, performance and stability. At present, mainstream router vendors like Cisco and Juniper announce that their routers can support IPv6 while some traditional IT equipment manufactures, especially those in Japan, think Internet upgrade caused by IPv6 will change the whole landscape of router market, which brings significant opportunities for them to enter router market. From 2000 to 2002, Hitachi, NEC and Fujitsu announced IPv6-capable core router to gain some market share in new Internet network. It must be admitted that IPv6 is still in the initial phase at present, which is reflected in the following aspects: most IPv6 network is in trial phase, the number of access users is low, carried IPv6 traffics cant be comparable to IPv4, the interoperability between IPv6 equipment still needs to be proved, and network engineers lack in experience in large-scale deployment and operation of IPv6 network. The lack of data and experience is one of important causes that make some operators lack in confidence in IPv6 network deployment. Many operators take wait-and-see attitudes. In order to prove IPv6 router (especially IPv6 core router), the support to IPv6, how are they performed and interoperated, provide a practical data basis for the operators to deploy IPv6 network and provide a reference for equipment manufactures to evaluate and improve their equipment, BII(Beijing Internet Institute) collaborate with 6TNet (IPv6 Telecom Trial Network) in China tested IPv6 core routers from 4 ven dors (Fujitsu, Hitachi, Juniper and NEC) in Beijing from October to December 2002. BII performed protocol conformance, performance andà interoperability tests. In these tests, we used the test instruments provided by Agilent and received strong technical support from Agilent. The test is not a comparative performance test in different router vendors. The purpose is to verify the feasibility of IPv6 deployment. With this test, the test team thinks that all SUT (system under test) has the ability to support commercial IPv6 network and provide basic IPv6 capabilities. They can support IPv6 routing protocols, support the forwarding of IPv6 datagram at wire rate and provide interoperability between them. From perspectives of pure technology, the test team thinks the products have been ready to deploy basic IPv6 core network.. Brief Descriptions of Test The requirements for hardware provided by the SUT (system under test) are as follows: IPv6-capable core router OC48 SM ports (both ports must be in different boards) Supports both FE ports and GE ports. The number of FE ports and GE ports is no less than 3 Finally, all vendors basically meet those requirements, although CX5210 provided by NEC doesnt support FE during the time of testing. The requirement for IPv6 capabilities provided by the SUT (system under test) include: support of IPv6 forwarding in hardware and support of related IPv6 routing protocols and migration strategy. Finally, all vendors meet our requirements as shown in the following table. Company IPv6 hardwareDual Stack RIPng OSPFv3 BGP4+ IPv6 over IPv4 forwarding Tunnel Fujitsu 9 9 9 9 9 9 Hitachi 9 9 9 9 9 9 Juniper 9 9 9 9 9 9 NEC 9 9 9 9 9 9 The SUT (system under test) models and OS versions are shown in the following table. Company Model Version Fujitsu Geostream R920 E10V02L03C44 Hitachi GR2000-20H S-9181-61 07-01 [ROUTE-OS6] Juniper M20 5.5R1.2 NEC CX5210 02.0(2e) 45.08.00 The test instruments we used in the test are as follows: Agilent Router Tester 900 Version: Router Tester 5.1,Build 11.15. Agilent QA Robot Version: Router Tester 5.3,Build 5.2 The IPv6 core router test is composed of three parts: Protocol conformance test, interoperability test and IPv6 performance test. Basic IPv6 Protocols and RIPng Basic IPv6 protocols include IPv6 Specification (RFC2460), ICMPv6 (RFC2463), Neighbor Discovery (RFC2461), Stateless Autoconfiguration (RFC2462), Path MTU Discovery (RFC1981), IPv6 address Architecture (RFC1884) and etc., which are basic capabilities provided by an IPv6 implementation. RIPng is defined by RFC2080 and is the extension and expansion of RIPv2. Its basic capabilities are same as RIPv2. The routing information exchanged by RIPng can carry IPv6 addresses and prefixes. RIPng runs on IPv6 network, uses multicasting address ff02::9 as destination to transfer routing information. RIPng is not compatible with RIPv2. RIP protocol is typically used in small networks and is not deployed in large networks because of its scalability and performance, which is same in IPv6 networks. The test does not include basic IPv6 protocols and RIPng because we think both capabilities are most basic and most preliminary capabilities that should be provided in an IPv6 router, these capabilities are implemented and interoperated very well in the routers from 4 vendors, and the 4 tested routers have been tested publicly or non-publicly several times in different occasions and provided good data. Therefore, we think it is unnecessary to make efforts to repeat these work and we skipped this test and focused on more challenged test items. BGP4+ Protocol Conformance Test At present, the external gateway protocol used in the IPv4 network is BGP4. Its basic protocols are defined in RFC1771. In order to carry IPv6 network information in BGP4 updates, IETF has defined a special property multi-protocol BGP (MP-BGP), also called IPv6 NLRI (Network Layer Reachability Information) to exchange IPv6 routing information, which is not a new version of BGP protocol, but an extension to BGP4. The extension is generally called BGP4+, which is compatible with BGP4. Refer to RFC2545 for its definition. Test Purpose and Used Standards: Purpose: To test the implementation of BGP4+ and conform with related standards for SUT (System Under Test). The following standards are referred in the test: Bates, T., Chandra, R., Katz, D. and Y. Rekhter, ââ¬Å"Multiprotocol Extension for BGP-4â⬠, RFC 2858, Jne 2000. Bates, T., Chandra, R., Chen, E., ââ¬Å"BGP Route Reflection An Alternative to Full Mesh IBGPâ⬠, RFC2796, April 2000. Chandra, R. and J.Scudder, ââ¬Å"Capabilities Advertisement with BGP-4â⬠, RFC 2842, May 2000. Dupont, F. and P. Marques, ââ¬Å"Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routingâ⬠, RFC 2545, March 1999. Rekhter, Y. and T. Li, ââ¬Å"A Border Gateway Protocol 4 (BGP-4) â⬠. Traina, P., McPherson, D., Scudder, J., ââ¬Å"Autonomous System Confederations for BGPâ⬠, RFC3065, February 2001. Test Methods: All the tests are based on topology emulation. One test port of instrument firstly establishes network topology emulation, then executes pre-written scripts, interacts with the port of SUT, performs related BGP4+ protocol tests individually and each test generates Passed/Failed record. The tests can be divided into active tests and passive tests. Active test means the tester is used to verify the state machine of SUT and the correctness of message format while passive test means the tester is used to interfere with SUT using messages with errors. Test Topology Test instrument and SUT use two independent Fast Ethernet or Gigabit Ethernet connections. All BGP4+ runs on the Fast Ethernet or Gigabit Ethernet connections. The physical topology is as follows: The logical topology is as follows: Test Items and Descriptions of Test Results: The BGP4+ protocol conformance test involves in the BGP multi-protocol extension, setup and transfer of BGP4+ IBGP and EBGP sessions, ability to receive IPv6 route updates, BGP4+ next hop, starting point, MED, local preference, AS_PATH, atom aggregation, community name and various properties, the ability of SUT to correctly process these properties, BGP4+ route reflector capability, BGP4+ federation capability. These tests can only ensure implementation of BGP4+protocol in SUT comply with the standard defined by RFC, and cant ensure SUT fully and successfully deploy BGP4+ routes in commercial IPv6 network. The following diagram briefly describes the test results. Attached table 1 includes all test items, description and detailed results of BGP4+ conformance tests for 4 routers. The test items and descriptions are extracted from RFC2858, RFC2545, RFC2842, RFC2796, RFC3065 and draft-ietf-idr-bgp4-14.txt part. Model Failed test items Fujitsu GeoStream R920 2 Hitachi GR2000-20H 5 Juniper M20 1 NEC CX5210 3 Analysis of Test Results: Capabilities not supported Confederation Route reflector, Community Fujitsus GeoStreamR920 of current version does not support BGP4+ federation capability. In all BGP4+ test items it supported, the general performance is fairly good. What needs to be improved is only one item that is to support the migration of undefined property and handle interim duration. It is hoped to improve null interface which cant support next hop at present. Hitachis GR2000-20H of current version supports all test items, and is only product fully supporting BGP4+ protocols in the core routers from 3 Japanese companies. However, it needs to be improved in the following areas: handling next-hop property of IBGP in BGP4+ protocol, using AS_PATH properties to prevent from route loop, the ability of route reflector to detect ORIGINATOR_ID. At the same time, we found in the interoperability test that GR2000-20H cant establish non-physical direct-connection sessions with IBGP peering entities, which Hitachi needs to improve. It is hoped to add loopback address capability. Junipers M20 passes all tests except one item excellently. NECs CX5210 of current version doesnt support BGP4+ route reflector and community properties. In all BGP4+ test items it supported, the general performance is fairly good. However, it needs to be improved in handling BGP4+ federation AS_CONFED_SEQUENCE property. It is hoped to add null interface configuration. Interoperability Test As above mentioned, IPv6 is in initial phase of commercial deployment at present. A large amount of IPv6-capable network equipments and terminals are available. IPv6 network built by the operators doesnt only use the equipment provided by a vendor. In multi-vendor network environment, the interoperability between equipment is vital. The interoperability test is composed of BGP4+ interoperability test and OSPFv3 interoperability test. It should be noted that specific items in the interoperability test only cover some most common properties of BGP4+ and OSPFv3, and are not the interoperability tests of all properties of BGP4+ and OSPFv3. BGP4+ Interoperability Establish IBGP Sessions Test Descriptions: The test is to verify GR2000-20H, CX5210, R920,M20 and fully meshed iBGP connections that can be established. Reference: RFC1771, RFC2545 and RFC2858. Test steps: GR2000-20H, CX5210, R920, M20 and SUT are connected as shown in the following diagram. 4 routers are in a same autonomous domain and are interconnected using IBGP protocol to form a full-meshed IBGP connection. Test instrument and SUT are interconnected using EBGP connection. Because GR2000-20H doesnt support IBGP across-router Session connection, we use a FE link to connect GR2000-20H to M20 to form a fully-meshed connection. Test Results: We verified whether iBGP sessions were established between GR2000-20H, CX5210, R920 and M20, and it was found all connections were set up successfully. GR2000-20H CX5210 R920 M20 GR2000-20H N/A OK OK OK CX5210 OK N/A OK OK R920 OK OK N/A OK M20 OK OK OK N/A EBGP- Route Advertisement Test Descriptions: To verify GR2000-20H, CX5210, R920 and M20 can advertise routes properly in a fully meshed networks. References: RFC1771, RFC2545 and RFC2858. Test steps: Establish network topology according to previous test, establish eBGP connection between tester and SUT, send 100 EBGP routes from tester to SUT. Results: We verified whether GR2000-20H, CX5210 and R920 and M20 routing tables were correct, and it was found all routing tables were correct. GR2000-20H CX5210 R920 M20 GR2000-20H N/A OK OK OK CX5210 OK N/A OK OK R920 OK OK N/A OK M20 OK OK OK N/A Establish EBGP Sessions Test Descriptions: The test is to verify GR2000-20H, CX5210, R920 and M20 can establish a fully meshed eBGP connections. Reference: RFC1771, RFC2545 and RFC2858. Test steps: GR2000-20H, CX5210, R920 and M20 are connected as shown in the following diagram. Test Descriptions: We verified whether EBGP sessions were established between GR2000-20H, CX5210, R920 and M20, and it was found all connections were established successfully. GR2000-20H CX5210 R920 M20 GR2000-20H N/A OK OK OK CX5210 OK N/A OK OK R920 OK OK N/A OK M20 OK OK OK N/A EBGP Route Advertisement Test Descriptions: To verify GR2000-20H, CX5210, R920 and M20 can advertise EBGP routes properly. References: RFC1771, RFC2545 and RFC2858. Test steps: Establish network topology according to previous tests, send routes from each router to all other routers. Test Results: We verified whether GR2000-20H, CX5210 and R920 and M20 routing tables were correct, and it was found all routing tables were correct. GR2000-20H CX5210 R920, M20r GR2000-20H N/A OK OK OK CX5210 OK N/A OK OK R920 OK OK N/A OK M20 OK OK OK N/A OSPFv3 Interoperability OSPF protocols supporting IPv6 is OSPFv3. OSPFv3 routing mechanism is basically same as OSPFv2. However, OSPFv2 relies primarily on IPv4, while OSPFv3 makes many improvements in OSPFv2 and is not a simple extension, thus OSPFv3, whose corresponding protocol is RFC2740, runs on IPv6. For real world applications, many operators regard OSPFv3 as a brand new protocol, also its stability and maturity need to be further verified, so when IPv6 routing protocols are selected, it tends to use IS-ISv6 (draft-ietf-isis-ipv6-02.txt), which is only a simple extension to IS-ISv4 (RFC1195) (2 TLVs re-defined) and does not make changes fully. However, it is sure the opinion is not authoritative and need to be proved. Because of the limitations of test instrument, It is required for SUT to provide 100M Ethernet interface. As CX5210 does not support Ethernet interface at present, just M20, R920 and GR2000-20H were involved in the testing. However, it does not imply that CX5210 cant interoperate with other 3 routers and has any problems with functions implementation. In the test, GR2000-20H is called SUT1 in short, M20 is called SUT2, and R920 is called SUT3. Establish OSPF Connections DR Election Test Descriptions: In the initial status, set different OSPF priority levels for SUT1, SUT2, SUT3 and the test instrument (10, 8, 5, 0). Connect these equipments based on the network topology below. Verify SUT1, SUT2, SUT3 and test instrument to establish OSPFv3 adjacency and vote DR/BDR. After DR/BDR is established properly, put DR off the network, and check whether DR/BDR is established properly. Put off-net equipment on the network, and check whether DR/BDR is established properly. Change OSPF initialization priorities of SUT1, SUT2, SUT3 and test instrument, and implement new test from step 2. Repeat the tests for 4 times, and ensure each SUT and test instrument have one opportunity to be selected as DR and BDR under the intial status. During the test, all SUTs are in the same OSPF Area 0. Reference: RFC2740 Test Results: During the testing, all the OSPF adjacencys can be established between SUTs and DR, also BDR can be elected properly. After DR is off-line, BDR can be re-elected as DR and the one with sub-top priority will be BDR. When off-line equipment is on-line again, no re-electing process occurs. All test results comply with the requirements in related standards. Exchange LSA Database Test Descriptions: Test instrument simulates an internal network with 4 routers connected, and sends the routing information to SUT. Then verify the routing information received by SUT DR from test instruments will be sent to DR Other correctly. Same as the previous test item, firstly SUT1 is used as DR, then SUT2, and finally SUT3. Reference: RFC2740 Test Results: During the testing, OSPF adjacency can be established properly between all SUTs. DR receive LSA information from test instrument and properly send the information to DR Other, which can also receive and process LSA information properly. IPv6 Performance Test The major approach used for the performance testing was to send the IPv6 traffic with different packet sizes and specific QoS information, via SUT to the destination, and then by the tester measure the throughput, latency and packet loss of SUT in various topologies. For the IPv6 performance test, there are four vendors high-end IPv6 routers, with OC-48 POS ports on which throughput and latency will be measured, with IPv6 packet sizes of 64 bytes, 128bytes, 256 bytes, 512 bytes, 1024 bytes, 1480 bytes and 1500 bytes. The performance in various of circumstances were measured, including IPv4/IPv6 mixed traffics (IPv4 and IPv6 traffics with different ratio), IPv6 traffic with packet sizes mixtures, Sweep Packet Sizes. Also the maximum routing table entry supported and the performance on manually configured tunnels were verified. Most of the referred standards is extracted from RFC2544. At present, there are deficient applications for IPv6, and the number of users in the IPv6 network can not be compared to IPv4. The sum of maximum IPv6 of IX(Internet eXchage) traffics is less than dozens of Mbits/s. These traffics can be handled using a router refitted from a PC. Based on the circumstance, is it necessary to test the performance of OC48 ports ? Actually when the operators build IPv6 network and purchase IPv6 routers, todays IPv6 network is not under their consideration. Their networks should be able to deal with the changes and growth of IPv6 network next 5 7 years. In this sense, it is necessary for IPv6 core router to support the IPv6 traffic forwarding capacities at wire rate. Otherwise, what differences can be made between a real IPv6 router and a router refitted from a PC with installed BSD and Zebra ? The measurement of the number of routing table entry also meets the same situations. At present, therere around 300-400 entries in the IPv6 backbone router routing table, which cant compared to the huge number of IPv4 (110,000à ¼Ã 130,000 routes). Secondly, IPv6 has drawn experience and lessons from IPv4 in design and address assignment. RIR only assigns the large block and fixed length IPv6 addresses to IPv6 operators, instead of the end users. To some extent, this can protect IPv6 routing tables from the explosive growth. The strict prefix filtering mechanism was set on BGP4+ routers by most of IPv6 network administrators and the router only allows minor prefixes, such as /16, /24, /28, /32, /35 and etc. However, the experience of IPv4 teach us a lesson- ââ¬Å"Money Talks!â⬠. In the fiercely competitive ages, it is very difficult for operators to reject users requirements. Under the conditions that IPv6 doesnt solve the problems of Multi-homing completely, it is possible that the network operators are required to broadcast users network prefixes into global IPv6 routing tables in order to achieve Multi-homing applications. So far RIR has begun to assign /48 ad dress segment to IPv6 of IX independently, while it is suggested IX doesnt broadcast the addresses. Thirdly, in many IPv6 networks, there are at least two IPv6 addresses segments, from 6BONE(3ffe::/16) and RIR(2001::/16) respectively, and maybe more prefixes will appear in the future. Fourthly, RIR cant ensure IPV6 addresses assigned to IPv6 operators are from a continuous address block. Current assignment policy indicates that /32 addresses of IPv6 assigned to operators can be continuously extended to /29. If new addresses are further required, they must be assigned to discontinuous address blocks and result in the growth of the number of routing tables. To sum up, the test team suggests that the number of IPv6 routing tables supported by the router should be no less than that of IPv4 routing tables, since it is very difficult to estimate the increasing number of routing tables of IPv6 core network right now. In current IPv6 networks, commercial IPv6 network and IPv6 trial network (6BONE) are interlaced without a explicit boundary between them. A packet from commercial IPv6 network may go through many IPv6 trial network before arriving at another IPv6 network. The network administrators of many trial networks are not regarded as a ââ¬Å"operatorsâ⬠, but a ââ¬Å"playersâ⬠It is pretty unstable of their networks, with routers reset very frequently. In the meantime, the networks advertise global IPv6 routes to all peers, making their own IPv6 network to implement transit. It causes the instability of current IPv6 of BGP routes, and thus it is required the capabilities of IPv6 routers cover the flapping and convergence properly, which should be included in this test, however due to limited test time frame, it is a pity the test team has to give up these tests. The network topology used for the performance test is shown as following: Ideally, the test topology should be as following, so that the packet forwarding capability of the routers in real-world network environment is shown completely. Send one traffic from a source port of the tester, via multiple ports of the router to the destination ports of tester, measure the performance of the router. However as the vendors cant provide enough OC48 ports, the test team can only perform the test by simply sending packets from one port and receiving packets form another port. In this sense, this test environment cant simulate completely the performance of the router in the real-world network environment. The Measurement of Throughput and Latency with Different IPv6 Packets Sizes at OC-48 POS port Test Descriptions: To test the maximum IPv6 packet forwarding rate of SUT with zero packet loss with different IPv6 packet sizes. Test Methods: Send IPv6 packets, via SUT to the destination ports of the tester, which measures the packet rate of SUT according to the received IPv6 packets. Set the initial offered load to 2%, and If no packet loss occurs, increase the offered load to 100% and repeat the test. If packet loss occurs, decrease the offered load to (100%+2%)/2=51%, repeat the test againâ⬠¦Ã¢â¬ ¦In a binary search manner, continue to increase or decrease the offered load in subsequent iterations until the difference in offered load between successful and failed tests is less than the resolution for the test. This is the zero-loss throughput rate. Traffic forwarding mode: full duplex. Offered Packet type: IPv6; Offered Packet size (bytes): 64 128 256 512 1024 1480 1500 Test duration of each packet type(s): 5 Bandwidth resolution (%): 0.1 Line BER tolerance (10^_): -10 The results are as follows: Sustainable Throughput of OC-48 POS Port 105.00% 100.00% 95.00% 90.00% 85.00% 80.00% 75.00% 70.00% 65.00% 60.00% 55.00% 50.00% 64 128 256 512 1024 1480 1500 bytes bytes bytes bytes bytes bytes bytes Test Packets Size Average Latency (us) at Variable Test Packets Size 100 90 80 70 60 50 40 30 20 10 0 Test Packets Size Hitachi NEC Fujistu Juniper Hitachi NEC Fujistu Juniper Note: About inherent latency of tester Before we perform tests, we must consider intrinsic latency of tester. The following table indicates inherent latency of tester for different test packet sizes when sending 100% offered load. Inherent latency of tester (100% offered load) Packet Size (bytes) 64 128 256 512 1024 1480 1500 Average Inherent 2.74 2.69 2.69 2.65 2.65 2.60 2.60 Latency (us) From the above, the inherent latency of tester under different packet sizes is about 2.7us. Compared to the tens of us of SUTs latency, there are not significant impacts on the test results. In addition, the impact of inherent latency is fair to these 4 SUTs. Forwarding Performance of IPv4/IPv6 Packets on OC48 Ports Test Descriptions: To verify the performance of SUT to forward IPv4/IPv6 packets in offered packets sizes. The test requires SUT to support IPv4/IPv6 dual protocol stacks. Test Methods: The tester sends IPv4 and IPv6 traffic simultaneously in full duplex configuration, via SUT to the destination port, measure the throughput and latency with various ratio of IPv4 and IPv6 traffic. Send traffic with 50% of IPv4 and 50% of IPv6 and 100% offered load first time. If packet loss occurs, decrease the offered load in 5% resolution until the difference in offered load between successful and failed tests is less than the resolution for the test. This is the zero-loss throughput rate. At the same time, measure the latency at maximum forwarding rate. Then change the ratio of IPv4 and IPv6 traffic to test again. Increase continuously the proportion of IPv6 traffic to simulate the change of traffic characteristics in the real-world network transition. Test Descriptions: Offered load (%): initial100% with 5% increment and final 0 Offered packet types: IPv6 Percentage of IPv4 and IPv6 traffic: 50:50ââ¬â10:90 (IPv4:IPv6) Offered packet size (bytes): 62 512 1518 Test duration of each packet size(s): 5 The test results are as follows: Sustainable throughput of OC-48 POS port at packet size 64 bytes with different percentage of IPv4 and IPv6 traffic Sustainable Throughput of OC-48 POS Port at Packet Size 64 bytes with different Percentage of IPv4 and IPv6 Traffic 105% 100% 95% 90% 85% Hitachi 80% NEC 75% Fujistu 70% Juniper 65% 60% 55% 50% 50/50 40/60 30/70 20/80 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Sustainable throughput of OC-48 POS port at packet size 512 bytes with different percentage of IPv4 and IPv6 traffic Sustainable Throughput of OC-48 POS Port at Packet Size 512 bytes with different Percentage of IPv4 and IPv6 Traffic 105% 100% 95% 90% 85% Hitachi 80% NEC 75% Fujistu 70% Juniper 65% 60% 55% 50% 50/50 40/60 30/70 20/80 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Sustainable throughput of OC-48 POS port at packet size 1518 bytes with different percentage of IPv4 and IPv6 traffic Sustainable Throughput of OC-48 POS Port at Packet Size 1518 bytes with different Percentage of IPv4 and IPv6 Traffic 105% 100% 95% 90% 85% Hitachi 80% NEC 75% Fujistu 70% Juniper 65% 60% 55% 50% 50/50 40/60 30/70 20/80 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Average latency (us) at test packets size 64 bytes with different percentage of IPv4 and IPv6 traffic Average Latency (us) at Test Packets Size 64 bytes with Different Percentage of IPv4 and IPv6 Traffic 100 90 80 70 60 50 40 30 20 10 0 50/50 40/6 30/70 20/80 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Hitachi NEC Fujistu Juniper Average latency (us) at test packets size 512 bytes with different percentage of IPv4 and IPv6 traffic Average Latency (us) at Test Packets Size 512 bytes with Different Percentage of IPv4 and IPv6 Traffic 100 90 80 70 60 50 40 30 20 10 0 50/50 40/60 30/70 20/80 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Hitachi NEC Fujistu Juniper Average latency (us) at test packets size 1518 bytes with different percentage of IPv4 and IPv6 traffic Average Latency (us) at Test Packets Size 1518 bytes with Different Percentage of IPv4 and IPv6 Traffic 100 90 80 70 60 50 40 30 20 10 0 50/50 40/60 30/70 20/80à à à à 10/90 IPv4/IPv6 Test Packets Percentage (IPv4/IPv6) Hitachi NEC Fujistu Juniper IPv6 over IPv4 Configured Tunneling Performance of OC-48 POS Port Test Description: Tunneling technology is an effective means to connect separate IPv6 networks via IPv4 backbone. This item is to verify the performance of SUT when SUT encapsulates IPv6 data packets into IPv4 payload and forwards the packets. Test Method: The tester sends IPv6 data packets to SUT, and configures an IPv6 over IPv4 tunnel between SUT and the tester. Thus after SUT receives pure IPv6 packets from the tester, it will encapsulate it into IPv4 packet payload, and send IPv6 packets to destination over IPv4 network. The tester analyzes the packets forwared by the SUT at receiving end, calculates the throughput of SUT for different sizes of packets under the IPv6 over IPv4 configured tunnel. Test Results: IPv6 packet size: 512 Destination address of sending IPv6 data packets: 3FFE:0:0:4::2/64 Bandwidth range of sending IPv6 tra
Wednesday, October 2, 2019
The Bell Jar :: essays research papers
It is 1953, and Esther Greenwood has just finished college for the year, and she has a won a one month internship at the Ladies Day magazine. She is one of twelve winners. All twelve girls are staying at the Amazon Hotel, while they deal with their hectic work schedule and social lives, as well. Estherââ¬â¢s boss for the month is Jay Cee, and Estherââ¬â¢s best friend for the month is Doreen. One night, Esther and Doreen were in a cab, on the way to one of the events that the Ladies Day had planned for them. They got stuck in a traffic jam, and ended up finding a man by the name of Lenny Shepherd. Esther and Doreen follow Lenny back to his apartment, and they all drink. Doreen and Lenny start getting more intimate, so Esther decides to leave and go back to the hotel, leaving Doreen there. Not too many days later, Esther attends a banquet with the other contest winners, and she indulges in caviar and crabmeat salad. Later, she feels sick and goes back to the hotel. All of the contest winners got food poisoning from the crabmeat salad. Near the end of the internship, Esther goes on a date with a man named Marco. Early on in the date, Esther knew she didnââ¬â¢t like him very much, and he ended up assaulting her. Esther was torn inside, and the next day she decided to go home to New England. When her mom picks her up, she told Esther of the news that she was not accepted into the writing program she worked so hard to apply to. Over the next few weeks, Esther becomes depressed. She refuses to bathe, and she wears the same clothes over and over. Her dream was to become a poet, but now she canââ¬â¢t even write. She goes to the Doctor, asking for more sleeping pills; instead he referred her to a psychiatrist. The psychiatrist is Dr. Gordon. He believed that Esther would do well with electro-shock treatments. She went to one, and hated it. It terrified her. After this, Esther becomes obsessed with suicide. She even attempted suicide a couple of times, but each time she was unsuccessful. She tried hanging herself, drowning herself, and slitting her wrists. One day, she decided to take a bunch of sleeping pills, and she woke up a couple of days later in the hospital.
Tuesday, October 1, 2019
American Education System Versus Asian Education System :: Compare Contrast School Asia USA Essays
American Education System versus Asian Education System à à à à à Today the American education system is no longer the best in the world. With declining test scores and poor academic achievement, people have questioned whether our current educational system is working for us. On the other side of the Pacific, the situation is totally different. Students of Asian countries achieve higher academic achievements, and they rank at the top on math and science tests. If their educational system is better than the U.S system, should we adopt their educational system, or not? à à à à à America the land of opportunity, which is famous for its democratic society and unique culture. People in America like to be free, to do whatever they want to do without any restrictions. This belief is reflected in the American educational system. In American schools, teachers and students are at the same social level. Students are encouraged to exchange their own opinions with the teacher. From an early age, students in the American educational system have been taught that they have the ability to achieve whatever they want to be, but rarely have been told how they can achieve their goal. This is because in America there are so many ways to achieve one's dream. à à à à à Because of this belief in natural born ability in the land of opportunity, students receive very little pressure in school, so whatever they do in school is totally based on their personal beliefs. If a student wants to be successful he or she can study very hard and get in to a very good college. On the other hand if a student doesn't have any self control and just wants to get school over with, it is OK too, because nobody cares. The advantage of this kind of educational system is that , it really developes student's individual thinking skills, they are encouraged to try out different options to achieve their goal. For example Bill Gates, who dropped out of college, started his own company, now he is one of the richest man in the world. That bad thing about this system is that not that many students don't have the responsibility to get good grades or become successful many believe that even if you don't have a good education you can still get a good paying job. That's why many students in school are doing poorly on their school work. à à à à à In Asian countries, the cultures and social standards are totally different from the U.S. In those countries most of their values are based on Confucius which heavily stresses education and group values. One's social status is based on their education level.
Berlin Conference
For three long months, 14 countries from Western Europe and the United States attended the Berlin Conference. This important conference is also known as Congo Conference or Berlin West Africa Conference. The countries that attended include Austria-Hungary, Belgium, Denmark, France, Germany, Great Britain, Italy, Netherlands, Portugal, Russia, Spain, Sweden-Norway, Turkey, and US.Interesting enough, not a single country of Africa attended even though the conference was entirely about the division of land on the African continent. The major players at this conference were the great and mighty countries of France, Germany, Great Britain, and Portugal. This conference that started on November 15, 1884 and ended on February 26, 1885 was called for by Portugal and organized by Otto von Bismarck, chancellor of Germany and minister of Prussia.The original goal of this lengthy conference was to agree that the Congo River and Niger River mouths and basins are neutral and are open to free trade . Before the conference, 80% of Africa remained to be traditionally and locally ruled. The Europeans only controlled the coastal areas. This all changed because King Leopold II wanted glory for Portugal and organized a secret mission to form Congo Free State. King Leopold and other countries wanted to take advantage of its gold, timber, land, timber, and labor power.When France discovered King Leopold IIââ¬â¢s scheme, she got mad which eventually resulted in this conference. The final result of this conference culminated in the General Act of BerlinConference. This document prohibited international slave trade, made Congo Free State a private property of Congo Society (although Leopold still uses it as his private property), permit free trade in Congo Basin and Lake Niassa, and allow free ship traffic on the Niger and Congo river.A new map of the African continent was created. It divided the vast continent into 50 geometric countries with no regards for cultural and linguistic bo undaries of the native Africans. The only countries remaining free are Ethiopia and Liberia (USââ¬â¢s country to return slaves to their ââ¬Å"homelandâ⬠. All in all, the Berlin Conference caused Africans to lose their autonomy and ushered in heightened colonial activity.
Subscribe to:
Posts (Atom)